Jeep Wrangler Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
The folks I bought my Jeep from put new bulbs in front and rear. It worked but blinked really slooooowww. Now it stays solid so I have to work it manually on off on off. Turn the hazards on and works as it should. Turn the hazards off turn the blinker on and it stays solid. The rear tail light housing is broken and there was moisture in it and I have a replacement on the way. Anyone heard of this or have suggestions?
 

·
Registered
Joined
·
9,643 Posts
Possibly the turn signal flasher. You should have two. One for your hazards and one for your turn signals. Try switching them to see if that fixes your signal problem. They should both be the same so you could leave it in until you can get a replacement for your hazards.
 

·
Premium Member
Joined
·
6,657 Posts
Sounds like your flasher to me. If you replace it get an EL12 then if you ever swap over to LED lights they will still flash.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I'm a newbie so please forgive. Would I have to replace the one for the signals as well as the one for the hazards?
 

·
Registered
Joined
·
9,643 Posts
Only if you go to the LED light like mentioned above. If you are leaving them stock, you will only need to replace the one that is not functioning. The one for your turn signals.
 

·
Premium Member
Joined
·
6,657 Posts
Simple fix and you can buy some time to get to the store by swapping them and maybe they will both start working since the hazards work differently then the turns do. If that doesn't fix it which it should we can then go from there.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Didn't get to work on signals today. Changed crank case and tranny oil then ran out of daylight. Will be on list to do this weekend. Thanks for the help.
 

·
Lazy Slacker
Joined
·
10,453 Posts
Curiously waiting to see if it's a fix..
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
Well that fixed turn signals but I have other electrical gremlins. When I have the headlights on and turn the turn signals on I lose all my lights on the back. The driver side rear tail light housing is cracked. I have another one ordered that should be here next week and I will start on that issue then. Thanks all.
 

·
Lazy Slacker
Joined
·
10,453 Posts
Time for a call to "painless wiring" ???
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
My new light came in and I installed today. Everything worked great. Swapped the flasher back around to the way it was and everything works as it should. Thanks to everyone for the help.
 

·
Lazy Slacker
Joined
·
10,453 Posts
Nice. .
 

·
Registered
Joined
·
1 Posts
Another noob here. I have the same flasher issue. You guys mention changing out the flasher as opposed to the bulb. Where/what is the flasher?
 

·
Registered
Joined
·
9,643 Posts
The flasher is a round thing that plugs into the fuse panel. There should be two of them plugged in there. One for your hazard light and one for your turn signals.

They look like this.



One to give you perspective on size.
 
1 - 19 of 19 Posts
Top