Jeep Wrangler Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have an 04 tj. It's a 4 cyl and in the past year I have had it the throttle position sensor has gone out on it 3 times. So I'm guessing there is an underlying problem there. Any ideas anyone?
 

·
Premium Member
Joined
·
1,560 Posts
Ive only had 1 go out on me so far. seems odd to have so many go out on you. do you have a throttle body spacer on or anything aftermarket?
 

·
Registered
Joined
·
54 Posts
Are you replacing it with OEM TPS's or ones from Autozone or your local shop? I've heard those at the auto shops may not be as consistent as the OEM version.

Having said that, mine went bad after a few too many high speed runs through a water hole at Windrock. Once I removed, cleaned the area, and installed a new one, it has been fine. And I got it from Autozone.

Do you see any signs of wiring wear/chafing on any wires? Have you cleaned the contacts where the TPS installs?
 

·
Resident Grouch
Joined
·
52 Posts
I have an 04 tj. It's a 4 cyl and in the past year I have had it the throttle position sensor has gone out on it 3 times. So I'm guessing there is an underlying problem there. Any ideas anyone?
If there is much wear in the throttle shaft bushing, the slop will cause the TPS wiper contact to be off center. Check your reference voltage just to eliminate that as a possible cause. That's all I can think of. My 2000 TJ 2.5 has 150k plus on it and still running the one from when she was new.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top