Jeep Wrangler Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
We checked the code said number 1 injector was bad so we replaced it and no dice. Replace plugs and wires still nothing. Pulled oil filler cap everything i can see is moving. Compression in number 4 was only at 40psi! He just bought the jeep three days ago and seller said it had a rebuild 1000 miles ago and no problems with it... All the gaskets up top and below apear to be new. Does anyone have any ideas?
 

·
Internet Owner
Joined
·
9,510 Posts
More details about the Jeep (year, engine, trans, etc...) would be helpful.
Is it getting spark at the plugs? Is it getting fuel at the fuel rail/throttle body?
 

·
Internet Owner
Joined
·
9,510 Posts
Could be a bad CPS (crank position sensor)
It is a sensor mounted on the bell housing near the top on the driver's side.
It tells the computer when the fuel should squirt and the coil sends power into the distributor.
Do you have a check engine light? Is that year OBD-II?
If so the code would help.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I will do some more digging and find out more specific details from my buddy. Thanks for the help i will keep you updated sir :)
 

·
Internet Owner
Joined
·
9,510 Posts
No problem. Let us know what it was for feel free to ask more questions.
And welcome to the site.
 

·
Resident Grouch
Joined
·
52 Posts
First off, WELCOME!! Now then, about the friend's Jeep.

OBDII can't tell if an injector is bad, just if that cylinder is misfiring, or if it is requiring an abnormal spark. Getting a professional diagnostic can save you $$ that you could waste throwing parts at something you aren't sure of.

Just because the head was re-done recently is no guarantee that it is ok.In fact, it is a reason to suspect that area even more. 40 psi is way low for a cranking compression. Did you do a wet test? Could be a weak, or broken valve spring. Or a bit of carbon under the valve seat. Like Rik said, we need more, accurate data to form an educated guess.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
The motor wasnt rebuilt after investigation. The previous owner lied and did a horrible job. Head bolts were cross threaded, cylinder walls wrecked among a long list of other problems. We went in on a totalled 97 tj at the local auction so he should be up and running in a month or so with a 4.0. Thanks for the help fellas
 
1 - 8 of 8 Posts
Top