Jeep Wrangler Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
1,560 Posts
Could you take a pic some can see the exact problem? Epoxy's work on some stuff really well but I wouldn't feel comfortable recommending it unless I could see the exact problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Turns out the seat belt was ok. the outer cover that surounds the latch mechanism was sliding down exposing the inner mechanism. I had tried pulling up on it before but yesterday I must have gotten a hold of it in the right place because it all the sudden slid up into place. I will take pictures if it works its way down again but if this happens to you try holding it in different places and angles until it slides back up
 

·
Registered
Joined
·
4 Posts
I have this same issue happening in my 04 Rubi. So far I've just been able to pull the black outer casing back up over the receiver assembly and it holds for a few months. When it gets to be a pain in the a55 I’ll use it as an excuse to the wife that I need new parts for the jeep.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I know mine pulls back up if I grab it low but just like yours it falls back down after a few weeks. New belt is almost $200 from Crapler. After market ones are not cheap either.

There must be a detent of some sort that is broken off that was supposed to hold it in place. I will photograph mine next week when it is back low. There is definately an issue because I met a guy last week that had the same issue

I have this same issue happening in my 04 Rubi. So far I've just been able to pull the black outer casing back up over the receiver assembly and it holds for a few months. When it gets to be a pain in the a55 I’ll use it as an excuse to the wife that I need new parts for the jeep.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top