2003 wrangler no oil pressure at idle add few rpm pressure over half way - Jeep Wrangler Forum


Go Back   Jeep Wrangler Forum > Jeep Wrangler Forums > TJ Jeep Wrangler OEM Forum

WranglerBoard.com is the premier Jeep Wrangler Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-20-2016, 02:34 AM   #1
264killer
Junior Member
Feedback Score: 0 reviews
 
Join Date Dec 2016
Location: Tuttle Oklahoma
Posts: 18
Default 2003 wrangler no oil pressure at idle add few rpm pressure over half way

Just joined to day. Just bought this to day. This is anew one on me.
264killer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-20-2016, 01:59 PM   #2
havasu
Moderator
Feedback Score: 0 reviews
 
havasu's Avatar
 
Join Date Nov 2011
Location: So Cal /Lake Havasu
Posts: 1,719
Default

Sounds like a bad oil pump or faulty gauges?
havasu is offline   Reply With Quote
Old 12-22-2016, 04:11 AM   #3
264killer
Junior Member
Feedback Score: 0 reviews
 
Join Date Dec 2016
Location: Tuttle Oklahoma
Posts: 18
Default

Was a bad sending unit.
264killer is offline   Reply With Quote
 
Old 12-22-2016, 02:48 PM   #4
havasu
Moderator
Feedback Score: 0 reviews
 
havasu's Avatar
 
Join Date Nov 2011
Location: So Cal /Lake Havasu
Posts: 1,719
Default

Glad to hear it was a cheap fix!
havasu is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools



All times are GMT. The time now is 02:06 AM.


Powered by vBulletin
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.